{"crate":{"id":"ssh-key","name":"ssh-key","updated_at":"2026-06-29T16:07:31.156954Z","versions":[2672270,2384796,2108332,1998477,1972463,1944673,1937920,1842799,1728864,1713417,1636643,1587168,1303173,1234326,1217263,1113364,1080322,1011852,962540,926077,872667,870892,831195,827535,763039,720272,649745,649690,648487,629145,628706,542642,539404,531282,517226,474680,462250,455506],"keywords":["certificate","crypto","openssh","ssh","sshsig"],"categories":["no-std","encoding","cryptography","authentication","parser-implementations"],"badges":[],"created_at":"2021-11-18T18:11:23.400176Z","downloads":13792625,"recent_downloads":6334674,"default_version":"0.6.7","num_versions":38,"yanked":false,"max_version":"0.7.0-rc.11","newest_version":"0.7.0-rc.11","max_stable_version":"0.6.7","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","links":{"version_downloads":"/api/v1/crates/ssh-key/downloads","versions":null,"owners":"/api/v1/crates/ssh-key/owners","owner_team":"/api/v1/crates/ssh-key/owner_team","owner_user":"/api/v1/crates/ssh-key/owner_user","reverse_dependencies":"/api/v1/crates/ssh-key/reverse_dependencies"},"exact_match":false,"trustpub_only":true},"versions":[{"id":2672270,"crate":"ssh-key","num":"0.7.0-rc.11","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.11/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.11/readme","updated_at":"2026-06-29T16:07:31.156954Z","created_at":"2026-06-29T16:07:31.156954Z","downloads":1859362,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes","cipher/chacha20poly1305","rand_core"],"getrandom":["cipher/getrandom","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes","dep:hmac","dep:argon2","dep:sha1"],"rand_core":["dep:rand_core","cipher/rand_core"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.11/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.11/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.11/authors"},"crate_size":141072,"published_by":null,"audit_actions":[],"checksum":"f9a32fae177b74a22aa9c5b01bf7e68b33545be32d9e381e248058d2adc15ce3","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":{"provider":"github","repository":"RustCrypto/SSH","run_id":"28385852624","sha":"7a1c757d2e2fcde32680e373d5226481de6d434e"},"linecounts":{"languages":{"Rust":{"code_lines":7820,"comment_lines":116,"files":38}},"total_code_lines":7820,"total_comment_lines":116}},{"id":2384796,"crate":"ssh-key","num":"0.7.0-rc.10","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.10/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.10/readme","updated_at":"2026-05-12T00:35:12.675674Z","created_at":"2026-05-12T00:35:12.675674Z","downloads":1162944,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.10/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.10/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.10/authors"},"crate_size":140871,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2026-05-12T00:35:12.675674Z"}],"checksum":"45735ce3dea95690e4a9e414c4cfde7f79835063c3dcd35881df85a84118e74b","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7798,"comment_lines":116,"files":38}},"total_code_lines":7798,"total_comment_lines":116}},{"id":2108332,"crate":"ssh-key","num":"0.7.0-rc.9","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.9/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.9/readme","updated_at":"2026-03-10T19:15:21.575170Z","created_at":"2026-03-10T19:15:21.575170Z","downloads":16358,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.9/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.9/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.9/authors"},"crate_size":138008,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2026-03-10T19:15:21.575170Z"}],"checksum":"8ae7221717f89c8629a83ba265a004cb864df267485656f790444fff1b69fa36","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7589,"comment_lines":113,"files":38}},"total_code_lines":7589,"total_comment_lines":113}},{"id":1998477,"crate":"ssh-key","num":"0.7.0-rc.8","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.8/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.8/readme","updated_at":"2026-02-04T16:16:06.919634Z","created_at":"2026-02-04T16:16:06.919634Z","downloads":10011,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.8/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.8/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.8/authors"},"crate_size":137949,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2026-02-04T16:16:06.919634Z"}],"checksum":"7011527e7cb07beea761652129ded405e47fdc153eb83dcc2dcefab39b50b08a","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7589,"comment_lines":113,"files":38}},"total_code_lines":7589,"total_comment_lines":113}},{"id":1972463,"crate":"ssh-key","num":"0.7.0-rc.7","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.7/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.7/readme","updated_at":"2026-01-25T21:38:59.057191Z","created_at":"2026-01-25T21:38:59.057191Z","downloads":170,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.7/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.7/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.7/authors"},"crate_size":137920,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2026-01-25T21:38:59.057191Z"}],"checksum":"7202396def6ed7a233bd4038a0f4c340a34eea9ac2000f8bb4f1ceedb752f917","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7590,"comment_lines":113,"files":38}},"total_code_lines":7590,"total_comment_lines":113}},{"id":1944673,"crate":"ssh-key","num":"0.7.0-rc.6","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.6/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.6/readme","updated_at":"2026-01-14T22:12:42.944830Z","created_at":"2026-01-14T22:12:42.944830Z","downloads":2845,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.6/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.6/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.6/authors"},"crate_size":137599,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2026-01-14T22:12:42.944830Z"}],"checksum":"6d1b3dd9b51062c9dfd6339675bcc2bab19e91400a08cc167227e9184e99d715","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7582,"comment_lines":111,"files":38}},"total_code_lines":7582,"total_comment_lines":111}},{"id":1937920,"crate":"ssh-key","num":"0.7.0-rc.5","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.5/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.5/readme","updated_at":"2026-01-12T14:53:35.917259Z","created_at":"2026-01-12T14:53:35.917259Z","downloads":42,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.5/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.5/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.5/authors"},"crate_size":136915,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2026-01-12T14:53:35.917259Z"}],"checksum":"c9919f7931e320cd6e070360fee461ee2974eff306cf23748d62dca276f78819","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7541,"comment_lines":112,"files":38}},"total_code_lines":7541,"total_comment_lines":112}},{"id":1842799,"crate":"ssh-key","num":"0.7.0-rc.4","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.4/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.4/readme","updated_at":"2025-11-25T16:20:52.954006Z","created_at":"2025-11-25T16:20:52.954006Z","downloads":9205,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.4/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.4/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.4/authors"},"crate_size":136152,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2025-11-25T16:20:52.954006Z"}],"checksum":"7faefb89d4a5304e31238913d1f7f164e22494276ed58cd84d5058ba7b04911f","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7536,"comment_lines":112,"files":38}},"total_code_lines":7536,"total_comment_lines":112}},{"id":1728864,"crate":"ssh-key","num":"0.7.0-rc.3","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.3/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.3/readme","updated_at":"2025-09-14T03:28:27.665219Z","created_at":"2025-09-14T03:28:27.665219Z","downloads":6100,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/os_rng"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc","dep:home"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.3/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.3/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.3/authors"},"crate_size":138035,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2025-09-14T03:28:27.665219Z"}],"checksum":"7307406fcbbeb6933b5c8cc84ec0fefee80fec53ba5b88b96674c0a75495090a","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7553,"comment_lines":111,"files":38}},"total_code_lines":7553,"total_comment_lines":111}},{"id":1713417,"crate":"ssh-key","num":"0.7.0-rc.2","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.2/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.2/readme","updated_at":"2025-09-03T18:53:29.460652Z","created_at":"2025-09-03T18:53:29.460652Z","downloads":746,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/os_rng"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc","dep:home"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.2/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.2/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.2/authors"},"crate_size":137913,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2025-09-03T18:53:29.460652Z"}],"checksum":"16638adc49b495978141fe7b55d6a6cdf3d176bc3528e2938788f2e73416b666","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7543,"comment_lines":111,"files":38}},"total_code_lines":7543,"total_comment_lines":111}},{"id":1636643,"crate":"ssh-key","num":"0.7.0-rc.1","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.1/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.1/readme","updated_at":"2025-07-10T23:12:30.534169Z","created_at":"2025-07-10T23:12:30.534169Z","downloads":668,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/os_rng"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc","dep:home"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.1/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.1/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.1/authors"},"crate_size":137907,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2025-07-10T23:12:30.534169Z"}],"checksum":"21e90b00851b983db0ede533ff59062e81994c2c1f035d3a75e972cbc49960e2","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7543,"comment_lines":111,"files":38}},"total_code_lines":7543,"total_comment_lines":111}},{"id":1587168,"crate":"ssh-key","num":"0.7.0-rc.0","dl_path":"/api/v1/crates/ssh-key/0.7.0-rc.0/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-rc.0/readme","updated_at":"2025-06-01T17:33:44.594626Z","created_at":"2025-06-01T17:33:44.594626Z","downloads":734,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:dsa","dep:sha1","alloc","encoding/bigint","signature/rand_core"],"ecdsa":["dep:sec1"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/os_rng"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"ppk":["dep:hex","alloc","cipher/aes-cbc","dep:hmac","dep:argon2","dep:sha1"],"rsa":["dep:rsa","alloc","encoding/bigint","rand_core"],"sha1":["dep:sha1"],"std":["alloc","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","dep:home"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-rc.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-rc.0/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-rc.0/authors"},"crate_size":136063,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2025-06-01T17:33:44.594626Z"}],"checksum":"39613381bf5e6994598ed4c9fd484cfe35ddf9c3b730955312acf6a8c9ccdbd6","rust_version":"1.85","has_lib":true,"bin_names":[],"edition":"2024","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.\n","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":7419,"comment_lines":111,"files":38}},"total_code_lines":7419,"total_comment_lines":111}},{"id":1303173,"crate":"ssh-key","num":"0.6.7","dl_path":"/api/v1/crates/ssh-key/0.6.7/download","readme_path":"/api/v1/crates/ssh-key/0.6.7/readme","updated_at":"2024-10-15T20:25:42.275296Z","created_at":"2024-10-15T20:25:42.275296Z","downloads":8578672,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.7/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.7/downloads","authors":"/api/v1/crates/ssh-key/0.6.7/authors"},"crate_size":112921,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2024-10-15T20:25:42.275296Z"}],"checksum":"3b86f5297f0f04d08cabaa0f6bff7cb6aec4d9c3b49d87990d63da9d9156a8c3","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6645,"comment_lines":92,"files":36}},"total_code_lines":6645,"total_comment_lines":92}},{"id":1234326,"crate":"ssh-key","num":"0.7.0-pre.1","dl_path":"/api/v1/crates/ssh-key/0.7.0-pre.1/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-pre.1/readme","updated_at":"2024-08-13T22:46:57.272809Z","created_at":"2024-08-13T22:46:57.272809Z","downloads":1420,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","signature/std","dep:home"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-pre.1/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-pre.1/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-pre.1/authors"},"crate_size":115750,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2024-08-13T22:46:57.272809Z"}],"checksum":"89e550203e9aa55d11b2a4b181c353d94f947ae58a1ab97053988539e1af5636","rust_version":"1.73","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6829,"comment_lines":93,"files":37}},"total_code_lines":6829,"total_comment_lines":93}},{"id":1217263,"crate":"ssh-key","num":"0.7.0-pre.0","dl_path":"/api/v1/crates/ssh-key/0.7.0-pre.0/download","readme_path":"/api/v1/crates/ssh-key/0.7.0-pre.0/readme","updated_at":"2024-07-28T17:19:18.153848Z","created_at":"2024-07-28T17:19:18.153848Z","downloads":1111,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.7.0-pre.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.7.0-pre.0/downloads","authors":"/api/v1/crates/ssh-key/0.7.0-pre.0/authors"},"crate_size":112881,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2024-07-28T17:19:18.153848Z"}],"checksum":"8b74bf76aa566fdddede93c19e6ad286d123151058a6239d865a0dd87d5a4ca0","rust_version":"1.73","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","documentation":null,"repository":"https://github.com/RustCrypto/SSH","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6612,"comment_lines":87,"files":36}},"total_code_lines":6612,"total_comment_lines":87}},{"id":1113364,"crate":"ssh-key","num":"0.6.6","dl_path":"/api/v1/crates/ssh-key/0.6.6/download","readme_path":"/api/v1/crates/ssh-key/0.6.6/readme","updated_at":"2024-04-12T19:22:00.351024Z","created_at":"2024-04-12T19:22:00.351024Z","downloads":973362,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.6/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.6/downloads","authors":"/api/v1/crates/ssh-key/0.6.6/authors"},"crate_size":111935,"published_by":{"id":11235,"login":"baloo","name":"Arthur Gautier","avatar":"https://avatars.githubusercontent.com/u/59060?v=4","url":"https://github.com/baloo","github_username_matches":true,"created_at":"2009-03-01T11:07:11Z"},"audit_actions":[{"action":"publish","user":{"id":11235,"login":"baloo","name":"Arthur Gautier","avatar":"https://avatars.githubusercontent.com/u/59060?v=4","url":"https://github.com/baloo","github_username_matches":true,"created_at":"2009-03-01T11:07:11Z"},"time":"2024-04-12T19:22:00.351024Z"}],"checksum":"ca9b366a80cf18bb6406f4cf4d10aebfb46140a8c0c33f666a144c5c76ecbafc","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6611,"comment_lines":87,"files":36}},"total_code_lines":6611,"total_comment_lines":87}},{"id":1080322,"crate":"ssh-key","num":"0.6.5","dl_path":"/api/v1/crates/ssh-key/0.6.5/download","readme_path":"/api/v1/crates/ssh-key/0.6.5/readme","updated_at":"2024-03-12T22:30:42.858524Z","created_at":"2024-03-12T22:30:42.858524Z","downloads":41637,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.5/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.5/downloads","authors":"/api/v1/crates/ssh-key/0.6.5/authors"},"crate_size":111264,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2024-03-12T22:30:42.858524Z"}],"checksum":"3b71299a724c8d84956caaf8fc3b3ea57c3587fe2d0b800cd0dc1f3599905d7e","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6588,"comment_lines":87,"files":36}},"total_code_lines":6588,"total_comment_lines":87}},{"id":1011852,"crate":"ssh-key","num":"0.6.4","dl_path":"/api/v1/crates/ssh-key/0.6.4/download","readme_path":"/api/v1/crates/ssh-key/0.6.4/readme","updated_at":"2024-01-12T04:27:02.245230Z","created_at":"2024-01-12T04:27:02.245230Z","downloads":65567,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.4/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.4/downloads","authors":"/api/v1/crates/ssh-key/0.6.4/authors"},"crate_size":110526,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2024-01-12T04:27:02.245230Z"}],"checksum":"01f8f4ea73476c0aa5d5e6a75ce1e8634e2c3f82005ef3bbed21547ac57f2bf7","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6547,"comment_lines":89,"files":36}},"total_code_lines":6547,"total_comment_lines":89}},{"id":962540,"crate":"ssh-key","num":"0.6.3","dl_path":"/api/v1/crates/ssh-key/0.6.3/download","readme_path":"/api/v1/crates/ssh-key/0.6.3/readme","updated_at":"2023-11-21T01:13:14.881186Z","created_at":"2023-11-21T01:13:14.881186Z","downloads":78774,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","p521","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"p521":["dep:p521","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","p521?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.3/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.3/downloads","authors":"/api/v1/crates/ssh-key/0.6.3/authors"},"crate_size":108422,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-11-21T01:13:14.881186Z"}],"checksum":"c51901eb883a5b442b506a1f8fa483d143f3bab513fe721e398ec56c77624feb","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6469,"comment_lines":88,"files":36}},"total_code_lines":6469,"total_comment_lines":88}},{"id":926077,"crate":"ssh-key","num":"0.6.2","dl_path":"/api/v1/crates/ssh-key/0.6.2/download","readme_path":"/api/v1/crates/ssh-key/0.6.2/readme","updated_at":"2023-10-15T20:13:53.247628Z","created_at":"2023-10-15T20:13:53.247628Z","downloads":51370,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.2/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.2/downloads","authors":"/api/v1/crates/ssh-key/0.6.2/authors"},"crate_size":107007,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-10-15T20:13:53.247628Z"}],"checksum":"2180b3bc4955efd5661a97658d3cf4c8107e0d132f619195afe9486c13cca313","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6415,"comment_lines":87,"files":36}},"total_code_lines":6415,"total_comment_lines":87}},{"id":872667,"crate":"ssh-key","num":"0.6.1","dl_path":"/api/v1/crates/ssh-key/0.6.1/download","readme_path":"/api/v1/crates/ssh-key/0.6.1/readme","updated_at":"2023-08-15T21:14:57.521258Z","created_at":"2023-08-15T21:14:57.521258Z","downloads":161223,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.1/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.1/downloads","authors":"/api/v1/crates/ssh-key/0.6.1/authors"},"crate_size":105909,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-08-15T21:14:57.521258Z"}],"checksum":"728fdf5286c394f12d83eaad51190af629aade5494813ce6b57f7425f1ca51b7","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6409,"comment_lines":87,"files":36}},"total_code_lines":6409,"total_comment_lines":87}},{"id":870892,"crate":"ssh-key","num":"0.6.0","dl_path":"/api/v1/crates/ssh-key/0.6.0/download","readme_path":"/api/v1/crates/ssh-key/0.6.0/readme","updated_at":"2023-08-13T15:35:49.176632Z","created_at":"2023-08-13T15:35:49.176632Z","downloads":3664,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.0/downloads","authors":"/api/v1/crates/ssh-key/0.6.0/authors"},"crate_size":105853,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-08-13T15:35:49.176632Z"}],"checksum":"4b0a17fec6ea344bfa1cda3aed2f0696fddc6295cfcc8c454a3bf58b8ffaabeb","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6409,"comment_lines":87,"files":36}},"total_code_lines":6409,"total_comment_lines":87}},{"id":831195,"crate":"ssh-key","num":"0.6.0-rc.2","dl_path":"/api/v1/crates/ssh-key/0.6.0-rc.2/download","readme_path":"/api/v1/crates/ssh-key/0.6.0-rc.2/readme","updated_at":"2023-06-25T15:54:05.612657Z","created_at":"2023-06-25T15:54:05.612657Z","downloads":8777,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.0-rc.2/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.0-rc.2/downloads","authors":"/api/v1/crates/ssh-key/0.6.0-rc.2/authors"},"crate_size":101506,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-06-25T15:54:05.612657Z"}],"checksum":"110fff26e39d649d1764dbaf7dd7c38da89752219c6c53ed09809dc42fd431a2","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6094,"comment_lines":85,"files":33}},"total_code_lines":6094,"total_comment_lines":85}},{"id":827535,"crate":"ssh-key","num":"0.6.0-rc.1","dl_path":"/api/v1/crates/ssh-key/0.6.0-rc.1/download","readme_path":"/api/v1/crates/ssh-key/0.6.0-rc.1/readme","updated_at":"2023-06-21T01:22:07.483654Z","created_at":"2023-06-21T01:22:07.483654Z","downloads":2027,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["ed25519","p256","p384","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["dep:bcrypt-pbkdf","alloc","cipher/aes-cbc","cipher/aes-ctr","cipher/aes-gcm","cipher/chacha20poly1305","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature/std"],"tdes":["cipher/tdes","encryption"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.0-rc.1/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.0-rc.1/downloads","authors":"/api/v1/crates/ssh-key/0.6.0-rc.1/authors"},"crate_size":101508,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-06-21T01:22:07.483654Z"}],"checksum":"9619543d3d4f0a96f7fc3c9f9715c54747897aaea69dad58b3cde00bc21de63c","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6094,"comment_lines":85,"files":33}},"total_code_lines":6094,"total_comment_lines":85}},{"id":763039,"crate":"ssh-key","num":"0.6.0-rc.0","dl_path":"/api/v1/crates/ssh-key/0.6.0-rc.0/download","readme_path":"/api/v1/crates/ssh-key/0.6.0-rc.0/readme","updated_at":"2023-03-30T02:53:50.879096Z","created_at":"2023-03-30T02:53:50.879096Z","downloads":6448,"features":{"aes-gcm":["dep:aes-gcm","encryption"],"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"crypto":["aes-gcm","ed25519","p256","p384","rsa"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["alloc","dep:aes","dep:bcrypt-pbkdf","dep:ctr","rand_core"],"getrandom":["rand_core/getrandom"],"p256":["dep:p256","ecdsa"],"p384":["dep:p384","ecdsa"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core"],"std":["alloc","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.0-rc.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.0-rc.0/downloads","authors":"/api/v1/crates/ssh-key/0.6.0-rc.0/authors"},"crate_size":98023,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-03-30T02:53:50.879096Z"}],"checksum":"483cc51fa8a159452bce88fea87cec78e299680f9d913ebfa4503e74d07871b1","rust_version":"1.65","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6250,"comment_lines":83,"files":34}},"total_code_lines":6250,"total_comment_lines":83}},{"id":720272,"crate":"ssh-key","num":"0.6.0-pre.0","dl_path":"/api/v1/crates/ssh-key/0.6.0-pre.0/download","readme_path":"/api/v1/crates/ssh-key/0.6.0-pre.0/readme","updated_at":"2023-02-06T03:54:05.928956Z","created_at":"2023-02-06T03:54:05.928956Z","downloads":3326,"features":{"alloc":["encoding/alloc","signature/alloc","zeroize/alloc"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","alloc","signature/rand_core"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["alloc","dep:aes","dep:bcrypt-pbkdf","dep:ctr","rand_core"],"getrandom":["rand_core/getrandom"],"rsa":["dep:bigint","dep:rsa","alloc","rand_core","sha2/oid"],"std":["alloc","ed25519-dalek?/std","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.6.0-pre.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.6.0-pre.0/downloads","authors":"/api/v1/crates/ssh-key/0.6.0-pre.0/authors"},"crate_size":95775,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2023-02-06T03:54:05.928956Z"}],"checksum":"7817fc025118e519e357a6680ab6dc5adbeb0282aec140c237eaa08a6f980f74","rust_version":"1.60","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6251,"comment_lines":88,"files":33}},"total_code_lines":6251,"total_comment_lines":88}},{"id":649745,"crate":"ssh-key","num":"0.5.1","dl_path":"/api/v1/crates/ssh-key/0.5.1/download","readme_path":"/api/v1/crates/ssh-key/0.5.1/readme","updated_at":"2022-10-25T18:23:03.149790Z","created_at":"2022-10-25T18:23:03.149790Z","downloads":205244,"features":{"alloc":["encoding/alloc","signature/hazmat-preview","zeroize/alloc"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","signature/rand-preview"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["alloc","dep:aes","dep:bcrypt-pbkdf","dep:ctr","rand_core"],"getrandom":["rand_core/getrandom"],"rsa":["dep:bigint","dep:rsa","sha2/oid"],"std":["alloc","ed25519-dalek?/std","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature?/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.5.1/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.5.1/downloads","authors":"/api/v1/crates/ssh-key/0.5.1/authors"},"crate_size":94718,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-10-25T18:23:03.149790Z"}],"checksum":"288d8f5562af5a3be4bda308dd374b2c807b940ac370b5efa1c99311da91d9a1","rust_version":"1.60","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6248,"comment_lines":88,"files":33}},"total_code_lines":6248,"total_comment_lines":88}},{"id":649690,"crate":"ssh-key","num":"0.5.0","dl_path":"/api/v1/crates/ssh-key/0.5.0/download","readme_path":"/api/v1/crates/ssh-key/0.5.0/readme","updated_at":"2022-10-25T16:46:40.052281Z","created_at":"2022-10-25T16:46:40.052281Z","downloads":1214,"features":{"alloc":["encoding/alloc","signature/hazmat-preview","zeroize/alloc"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","signature/rand-preview"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["alloc","dep:aes","dep:bcrypt-pbkdf","dep:ctr","rand_core"],"getrandom":["rand_core/getrandom"],"rsa":["dep:bigint","dep:rsa","sha2/oid"],"std":["alloc","ed25519-dalek?/std","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature?/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.5.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.5.0/downloads","authors":"/api/v1/crates/ssh-key/0.5.0/authors"},"crate_size":94669,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-10-25T16:46:40.052281Z"}],"checksum":"2870aec6091176f89a2798dce5307dad6a3909a7ab726ba9a8926bfcf252a871","rust_version":"1.60","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6248,"comment_lines":88,"files":33}},"total_code_lines":6248,"total_comment_lines":88}},{"id":648487,"crate":"ssh-key","num":"0.5.0-rc.0","dl_path":"/api/v1/crates/ssh-key/0.5.0-rc.0/download","readme_path":"/api/v1/crates/ssh-key/0.5.0-rc.0/readme","updated_at":"2022-10-24T03:45:52.022127Z","created_at":"2022-10-24T03:45:52.022127Z","downloads":1131,"features":{"alloc":["encoding/alloc","signature/hazmat-preview","zeroize/alloc"],"default":["ecdsa","rand_core","std"],"dsa":["dep:bigint","dep:dsa","dep:sha1","signature/rand-preview"],"ecdsa":["dep:sec1"],"ed25519":["dep:ed25519-dalek","rand_core"],"encryption":["alloc","dep:aes","dep:bcrypt-pbkdf","dep:ctr","rand_core"],"getrandom":["rand_core/getrandom"],"rsa":["dep:bigint","dep:rsa","sha2/oid"],"std":["alloc","ed25519-dalek?/std","encoding/std","p256?/std","p384?/std","rsa?/std","sec1?/std","signature?/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.5.0-rc.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.5.0-rc.0/downloads","authors":"/api/v1/crates/ssh-key/0.5.0-rc.0/authors"},"crate_size":94468,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-10-24T03:45:52.022127Z"}],"checksum":"9f15435579b813337988ae558cd22b6e174793171f6b34d1a8adfb6a07a222cd","rust_version":"1.60","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251/RFC4253 and OpenSSH key formats, as well as \"sshsig\" signatures and\ncertificates (including certificate validation and certificate authority support),\nwith further support for the `authorized_keys` and `known_hosts` file formats.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6248,"comment_lines":88,"files":33}},"total_code_lines":6248,"total_comment_lines":88}},{"id":629145,"crate":"ssh-key","num":"0.5.0-pre.0","dl_path":"/api/v1/crates/ssh-key/0.5.0-pre.0/download","readme_path":"/api/v1/crates/ssh-key/0.5.0-pre.0/readme","updated_at":"2022-09-26T15:14:25.340455Z","created_at":"2022-09-26T15:14:25.340455Z","downloads":1169,"features":{"alloc":["signature","zeroize/alloc","base64ct/alloc"],"default":["ecdsa","fingerprint","rand_core","std"],"ecdsa":["sec1"],"ed25519":["ed25519-dalek","rand_core"],"encryption":["aes","alloc","bcrypt-pbkdf","ctr","rand_core"],"fingerprint":["sha2"],"getrandom":["rand_core/getrandom"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.5.0-pre.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.5.0-pre.0/downloads","authors":"/api/v1/crates/ssh-key/0.5.0-pre.0/authors"},"crate_size":91976,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-09-26T15:14:25.340455Z"}],"checksum":"6476e753c6d40cfbaba493a5ed6d885647774664c1a19a697c67fa09ee40f48e","rust_version":"1.57","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251 and RFC4253 as well as the OpenSSH key formats, certificates\n(including certificate validation and certificate authority support), and\nthe `authorized_keys` and `known_hosts` file formats. Supports a `no_std`\nprofile for embedded targets.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6017,"comment_lines":86,"files":37}},"total_code_lines":6017,"total_comment_lines":86}},{"id":628706,"crate":"ssh-key","num":"0.4.3","dl_path":"/api/v1/crates/ssh-key/0.4.3/download","readme_path":"/api/v1/crates/ssh-key/0.4.3/readme","updated_at":"2022-09-25T22:46:48.830712Z","created_at":"2022-09-25T22:46:48.830712Z","downloads":397182,"features":{"alloc":["signature","zeroize/alloc","base64ct/alloc"],"default":["ecdsa","fingerprint","rand_core","std"],"ecdsa":["sec1"],"ed25519":["ed25519-dalek","rand_core"],"encryption":["aes","alloc","bcrypt-pbkdf","ctr","rand_core"],"fingerprint":["sha2"],"getrandom":["rand_core/getrandom"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.4.3/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.4.3/downloads","authors":"/api/v1/crates/ssh-key/0.4.3/authors"},"crate_size":91775,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-09-25T22:46:48.830712Z"}],"checksum":"f02d3730e8785e797a4552137d1acc0d7f7146dad3b5fe65ed83637711dfc6c5","rust_version":"1.57","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251 and RFC4253 as well as the OpenSSH key formats, certificates\n(including certificate validation and certificate authority support), and\nthe `authorized_keys` and `known_hosts` file formats. Supports a `no_std`\nprofile for embedded targets.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/SSH/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6008,"comment_lines":86,"files":37}},"total_code_lines":6008,"total_comment_lines":86}},{"id":542642,"crate":"ssh-key","num":"0.4.2","dl_path":"/api/v1/crates/ssh-key/0.4.2/download","readme_path":"/api/v1/crates/ssh-key/0.4.2/readme","updated_at":"2022-05-02T17:19:11.152388Z","created_at":"2022-05-02T17:19:11.152388Z","downloads":101365,"features":{"alloc":["signature","zeroize/alloc","base64ct/alloc"],"default":["ecdsa","fingerprint","rand_core","std"],"ecdsa":["sec1"],"ed25519":["ed25519-dalek","rand_core"],"encryption":["aes","alloc","bcrypt-pbkdf","ctr","rand_core"],"fingerprint":["sha2"],"getrandom":["rand_core/getrandom"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.4.2/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.4.2/downloads","authors":"/api/v1/crates/ssh-key/0.4.2/authors"},"crate_size":92354,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-05-02T17:19:11.152388Z"}],"checksum":"9e09d8b0ff2fca365c89ad535055c17adbd9fb0a5daf338299049882e95b6931","rust_version":"1.57","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251 and RFC4253 as well as the OpenSSH key formats, certificates\n(including certificate validation and certificate authority support), and\nthe `authorized_keys` and `known_hosts` file formats. Supports a `no_std`\nprofile for embedded targets.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/formats/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":6008,"comment_lines":87,"files":37}},"total_code_lines":6008,"total_comment_lines":87}},{"id":539404,"crate":"ssh-key","num":"0.4.1","dl_path":"/api/v1/crates/ssh-key/0.4.1/download","readme_path":"/api/v1/crates/ssh-key/0.4.1/readme","updated_at":"2022-04-26T23:12:22.030073Z","created_at":"2022-04-26T23:12:22.030073Z","downloads":1723,"features":{"alloc":["signature","zeroize/alloc"],"default":["ecdsa","fingerprint","rand_core","std"],"ecdsa":["sec1"],"ed25519":["ed25519-dalek","rand_core"],"encryption":["aes","alloc","bcrypt-pbkdf","ctr","rand_core"],"fingerprint":["sha2"],"getrandom":["rand_core/getrandom"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.4.1/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.4.1/downloads","authors":"/api/v1/crates/ssh-key/0.4.1/authors"},"crate_size":85928,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-04-26T23:12:22.030073Z"}],"checksum":"3b184103bba54f44c1839ecdea4353df91c5ffd05bb05639c574e1b2a399fb3e","rust_version":"1.57","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251 and RFC4253 as well as the OpenSSH key formats, certificates\n(including certificate validation and certificate authority support), and\nthe `authorized_keys` file format. Supports `no_std` embedded targets.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/formats/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":5608,"comment_lines":75,"files":36}},"total_code_lines":5608,"total_comment_lines":75}},{"id":531282,"crate":"ssh-key","num":"0.4.0","dl_path":"/api/v1/crates/ssh-key/0.4.0/download","readme_path":"/api/v1/crates/ssh-key/0.4.0/readme","updated_at":"2022-04-12T16:19:13.902036Z","created_at":"2022-04-12T16:19:13.902036Z","downloads":1407,"features":{"alloc":["signature","zeroize/alloc"],"default":["ecdsa","fingerprint","rand_core","std"],"ecdsa":["sec1"],"ed25519":["ed25519-dalek","rand_core"],"encryption":["aes","alloc","bcrypt-pbkdf","ctr","rand_core"],"fingerprint":["sha2"],"getrandom":["rand_core/getrandom"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.4.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.4.0/downloads","authors":"/api/v1/crates/ssh-key/0.4.0/authors"},"crate_size":84867,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-04-12T16:19:13.902036Z"}],"checksum":"b6387edc9cff6c3c6572fcdcfb632a52b61e09d418a75ffa42fcbb1d6751fa3c","rust_version":"1.57","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4251 and RFC4253 as well as the OpenSSH key formats, certificates\n(including certificate validation and certificate authority support), and\nthe `authorized_keys` file format. Supports `no_std` embedded targets.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/formats/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":5498,"comment_lines":74,"files":35}},"total_code_lines":5498,"total_comment_lines":74}},{"id":517226,"crate":"ssh-key","num":"0.3.0","dl_path":"/api/v1/crates/ssh-key/0.3.0/download","readme_path":"/api/v1/crates/ssh-key/0.3.0/readme","updated_at":"2022-03-16T14:16:52.962411Z","created_at":"2022-03-16T14:16:52.962411Z","downloads":13841,"features":{"alloc":["zeroize/alloc"],"default":["ecdsa","fingerprint","std"],"ecdsa":["sec1"],"fingerprint":["sha2"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.3.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.3.0/downloads","authors":"/api/v1/crates/ssh-key/0.3.0/authors"},"crate_size":47464,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2022-03-16T14:16:52.962411Z"}],"checksum":"b46e992df5347ae7777db4c1fbf8cd086314a64c0a538222c31e62d5b4f9dee7","rust_version":"1.57","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4253 and RFC4716 as well as the OpenSSH key formats and `authorized_keys`.\nSupports \"heapless\" `no_std` embedded targets with an optional `alloc` feature.","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/formats/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":2711,"comment_lines":52,"files":19}},"total_code_lines":2711,"total_comment_lines":52}},{"id":474680,"crate":"ssh-key","num":"0.2.0","dl_path":"/api/v1/crates/ssh-key/0.2.0/download","readme_path":"/api/v1/crates/ssh-key/0.2.0/readme","updated_at":"2021-12-29T23:53:22.132357Z","created_at":"2021-12-29T23:53:22.132357Z","downloads":12114,"features":{"alloc":[],"default":["alloc","ecdsa"],"ecdsa":["sec1"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.2.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.2.0/downloads","authors":"/api/v1/crates/ssh-key/0.2.0/authors"},"crate_size":34217,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2021-12-29T23:53:22.132357Z"}],"checksum":"44c85ed79c3ce171194a27b20afc7114a5ba0e416e95ed061701aa0c7941afd2","rust_version":"1.56","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4253 and RFC4716 as well as the OpenSSH key formats. Supports \"heapless\"\n`no_std` embedded targets with an optional `alloc` feature (Ed25519 and ECDSA only)","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/formats/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":1413,"comment_lines":33,"files":17}},"total_code_lines":1413,"total_comment_lines":33}},{"id":462250,"crate":"ssh-key","num":"0.1.0","dl_path":"/api/v1/crates/ssh-key/0.1.0/download","readme_path":"/api/v1/crates/ssh-key/0.1.0/readme","updated_at":"2021-12-03T01:36:02.713154Z","created_at":"2021-12-03T01:36:02.713154Z","downloads":1277,"features":{"alloc":[],"default":["alloc","sec1"],"std":["alloc","base64ct/std"]},"yanked":false,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.1.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.1.0/downloads","authors":"/api/v1/crates/ssh-key/0.1.0/authors"},"crate_size":26613,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2021-12-03T01:36:02.713154Z"}],"checksum":"f3d4ecf1bfb95ccf2f9e76d291d3acdf2ec1a037283fec58c1e95ae4fb00654c","rust_version":"1.56","has_lib":true,"bin_names":[],"edition":"2021","description":"Pure Rust implementation of SSH key file format decoders/encoders as described\nin RFC4253 and RFC4716 as well as the OpenSSH key formats. Supports \"heapless\"\n`no_std` embedded targets with an optional `alloc` feature (Ed25519 and ECDSA only)","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/formats/tree/master/ssh-key","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":690,"comment_lines":14,"files":7}},"total_code_lines":690,"total_comment_lines":14}},{"id":455506,"crate":"ssh-key","num":"0.0.0","dl_path":"/api/v1/crates/ssh-key/0.0.0/download","readme_path":"/api/v1/crates/ssh-key/0.0.0/readme","updated_at":"2021-12-03T01:36:08.755354Z","created_at":"2021-11-18T18:11:23.400176Z","downloads":1171,"features":{},"yanked":true,"yank_message":null,"lib_links":null,"license":"Apache-2.0 OR MIT","links":{"dependencies":"/api/v1/crates/ssh-key/0.0.0/dependencies","version_downloads":"/api/v1/crates/ssh-key/0.0.0/downloads","authors":"/api/v1/crates/ssh-key/0.0.0/authors"},"crate_size":678,"published_by":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"audit_actions":[{"action":"publish","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2021-11-18T18:11:23.400176Z"},{"action":"yank","user":{"id":267,"login":"tarcieri","name":"Tony Arcieri","avatar":"https://avatars.githubusercontent.com/u/797?v=4","url":"https://github.com/tarcieri","github_username_matches":true,"created_at":"2008-02-25T04:32:26Z"},"time":"2021-12-03T01:36:08.760556Z"}],"checksum":"4670df052700ca749337639361a97cd0cf34496e6baeb8721d2260db2afe8e61","rust_version":null,"has_lib":true,"bin_names":[],"edition":"2018","description":"Reserved for future use","homepage":null,"documentation":null,"repository":"https://github.com/RustCrypto/traits","trustpub_data":null,"linecounts":{"languages":{"Rust":{"code_lines":0,"comment_lines":0,"files":1}},"total_code_lines":0,"total_comment_lines":0}}],"keywords":[{"id":"certificate","keyword":"certificate","created_at":"2016-03-07T12:49:34.868709Z","crates_cnt":177},{"id":"crypto","keyword":"crypto","created_at":"2014-11-24T02:30:36.413823Z","crates_cnt":2682},{"id":"openssh","keyword":"openssh","created_at":"2017-09-20T22:02:37.299257Z","crates_cnt":35},{"id":"ssh","keyword":"ssh","created_at":"2014-11-11T06:39:04.932316Z","crates_cnt":539},{"id":"sshsig","keyword":"sshsig","created_at":"2022-10-24T03:45:52.022127Z","crates_cnt":7}],"categories":[{"id":"no-std","category":"No standard library","slug":"no-std","description":"Crates that are able to function without the Rust standard library.","created_at":"2017-02-10T01:52:09.447906Z","crates_cnt":13695},{"id":"encoding","category":"Encoding","slug":"encoding","description":"Encoding and/or decoding data from one data format to another.","created_at":"2017-01-17T19:13:05.112025Z","crates_cnt":7491},{"id":"cryptography","category":"Cryptography","slug":"cryptography","description":"Algorithms intended for securing data.","created_at":"2017-01-17T19:13:05.112025Z","crates_cnt":7888},{"id":"authentication","category":"Authentication","slug":"authentication","description":"Crates to help with the process of confirming identities.","created_at":"2017-01-17T19:13:05.112025Z","crates_cnt":2934},{"id":"parser-implementations","category":"Parser implementations","slug":"parser-implementations","description":"Parsers implemented for particular formats or languages.","created_at":"2017-02-05T21:31:23.444608Z","crates_cnt":7766}]}